Performance degradation affecting Rwanda MTN services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 23:15 UTC

Update

We have identified instability in Rwanda MTN services. We have escalated this to the MMO for resolution.
Posted Oct 23, 2025 - 17:53 UTC

Update

We have identified instability in Rwanda MTN services. We have escalated this to the MMO for resolution.
Posted Oct 23, 2025 - 16:31 UTC

Identified

We have identified instability in Rwanda MTN services. We have escalated this to the MMO for resolution.
Posted Oct 23, 2025 - 16:18 UTC
This incident affected: Rwanda MMO services (MTN :: Web Deposit, MTN :: Payout).