Performance degradation affecting Zambia Zamtel NFS services

Incident Report for pawaPay

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Oct 26, 2025 - 20:54 UTC

Identified

We have identified instability in Zambia Zamtel NFS services. We have escalated this to the MNO for resolution.
Posted Oct 26, 2025 - 19:39 UTC
This incident affects: Zambia MMO services (Zamtel :: Payout).