Performance degradation affecting Lesotho M-Pesa services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 03:18 UTC

Investigating

We are experiencing an outage of the Lesotho M-Pesa services. We are investigating the issue.
Posted Sep 09, 2026 - 23:58 UTC
This incident affected: Lesotho MMO services (M-Pesa :: Web Deposit, M-Pesa :: Payout).