Performance degradation affecting USSD services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 13:19 UTC

Monitoring

We are pleased to inform you that our engineering team has deployed a fix and we are currently monitoring our systems for results. Thank you for your patience.
Posted Oct 22, 2025 - 12:22 UTC

Investigating

We are experiencing an outage in our USSD deposit services. We are investigating the issue.
Posted Oct 22, 2025 - 11:41 UTC
This incident affected: Zambia MMO services (Airtel :: USSD Deposit, Zamtel :: USSD Deposit), Kenya MMO services (M-Pesa :: USSD Deposit), Tanzania MMO services (Airtel :: USSD Deposit, Halotel :: USSD Deposit, Yas :: USSD Deposit), and Uganda MMO services (MTN :: USSD Deposit).