The incident has been resolved. We apologise for the inconvenience.
Posted Sep 04, 2026 - 23:38 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Sep 04, 2026 - 20:08 UTC
Investigating
We are experiencing an outage of the Cameroon Orange services. We are investigating the issue.
Posted Sep 04, 2026 - 19:02 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Sep 04, 2026 - 18:51 UTC
Identified
Cameroon Orange is still facing an outage on their platform. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Sep 04, 2026 - 17:30 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Sep 04, 2026 - 15:38 UTC
Investigating
We are experiencing an outage of the Cameroon Orange services. We are investigating the issue.
Posted Sep 04, 2026 - 14:21 UTC
This incident affected: Cameroon MMO services (Orange :: Web Deposit, Orange :: Payout).