Performance degradation affecting Nigeria Opay services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 00:28 UTC

Investigating

We are experiencing degraded performance in the Nigeria Opay services. We are investigating the issue.
Posted Oct 19, 2025 - 21:36 UTC
This incident affected: Nigeria MMO services (Opay :: Web Deposit, Opay :: Payout).